Computer Network Assignment: Implementing Network Infrastructure for Gogol.co.uk
Question
Computer Network Assignment Instructions:
Rationale/expectations: This is an individual assignment based on the case study scenario presented below. This assignment will assess your understanding of the principles of network design and the ability to analyse, design and create a network infrastructure fully configured and tested which would reflect your understanding of network design and troubleshooting.
Scenario
You are working as a network engineer in an IT company. You have been assigned to design, implement a network infrastructure for a small company named Gogol.co.uk which consists of 3 department HR /Finance, Sales and Admin. Each department must not be able to access any other departments.
The network consists of four Servers namely web, email, dns, and common file server which are shared by all users. The distribution of workstation shown in table 1, describes the requirement of each department. The administrative department (Admin) decided to use wireless network for use by any staff using their own wireless device such as smartphone to access the Internet.
The IT director emphasised on scalability, availability, and asked for an additional monitoring tools using IoT, to monitor the server room temperature, access door etc…
You are required to provide a complete network infrastructure design and implementation for which the network availability, scalability and security are very important. To do so, the company will be using a private IP address 71.81.91.0/24 within LAN, the company. The wireless network IP address is 10.11.0.0/16.
Task
Analyse the requirements given in above scenario by evaluating suitable network model and components to design a network infrastructure featuring scalability, availability and security.
Based on your analysis and evaluation, you are to apply the required configuration for the selected components / technologies, and finally, you are to discuss, evaluate and apply Network monitoring tools/components, and produce a network test and documentation suitable for network maintenance. All relevant network configuration, network diagram and device configuration tables, network simulation files must be included.
Answer
Introduction
The purpose of the computer network assignment is to implement a secured network infrastructure for a company named Gogol.co.uk. The company consists of three departments Finance/HR, Sales and Admin. Each department should not be able to access any other departments but must be able to access four servers of the company. The network consists of four servers which are DNS, web, email and common file. The network also consists of wireless network and admin department will access through their wireless devices.
The information of the devices of the departments are given below.
Department |
Devices |
Finance/HR |
6 computers and 1 printer |
Sales |
52 computers and 1 printer |
Admin |
30 computers and 1 printer |
Wireless Devices |
Should be sufficient for students and staff |
Servers |
DNS, Web, Email, Common file |
Table-1
Definitions
- VLAN – It is Virtual Local Area Network and used to logically isolate the physical LAN.
- DNS – It is Domain Name System and used to translate domain names to IP addresses.
- Email – It is electronic mail and used to exchange massages through internet.
- Inter VLAN routing – It is configured so that all VLANs can communicate to each other.
Requirements
- All three departments must not communicate to each other.
- End devices must communicate to servers.
- All wireless devices must not communicate to other departments but must communicate to servers.
Inventory List
Sr.No. |
Devices |
Quantity |
1 |
Access switches |
6 |
2 |
Core Switch |
1 |
3 |
Layer 3 switch |
1 |
4 |
Access Point |
1 |
5 |
Servers |
4 |
6 |
Computers |
78 |
7 |
Printers |
3 |
8 |
Laptops |
3 |
Table-2
Purpose of selected devices
- Access Switch
Access switches are basically used to connect end devices to network. I have used 6 24-port access switch in the network design. 1 is used for finance/HR department to connect 6 computers and 1 printer. 3 access switches are used to connect 52 computers and 1 printer. 2 access switches are used for admin department to connect 30 computers and 1 printer. - Core Switch
It is basically a backbone switch of the network and also it is serving as a gateway to internet and all the departments. I have used 1 core switch to connect all the access switches of all three departments. It is also used to connect access point and all the servers. - Layer 3 switch
I have used the layer-3 switch to enable the inter VLAN routing between the servers and all the departments of company. So that all the end users can access to the servers. - Access Point
I have used access point to communicate the all the wireless end devices
Computer Network Components
Computer network components can be hardware or software components which is needed to design the network infrastructure of the any organization. The hardware components can be routers, switches, servers, access points and firewalls. The software components can be operating systems and licenses etc.
Figure-1
Hardware Components
- Servers
Servers are configurable computer which can be configure as per the design requirements. Server can be configured as file servers, DNS server, DHCP servers, NTP server, database etc. In this project, we have use DNS, Web, Email and file servers. Different operating systems can be installed in server like windows server or VMware esxi. - Clients
Clients are basically end user devices which can receive and send different types of information to servers and can access other network components installed in network infrastructure. Clients can be personal computers, laptops or mobiles. - Transmission Media
Transmission media is basically a medium through which information travels throughout the infrastructure between clients and other components. Transmission media can be fiber optics, UTP cables, coaxial cables, microwave etc. - Connecting Devices
Connecting devices are middle devices in the network infrastructure which can connect end user devices to the internet. Most common connecting devices are routers, hubs, switches etc. In this project, I have used switches as a connecting device.
Network Models
Network models are basically responsible for establishing a connection between the receiver and sender and transmitting the data in effective manner respectively.
There are two types of computer network models, these are:
- TCP/IP Model
- OSI Model
TCP/IP Model
TCP/IP model help us to find that how a client will be connected to the internet and how the data will be transmitted among the layers of this model.
There are four layers of TCP/IP model:
- Application layer
- Transport layer
- Internet layer
- Network interface
All four layers of TCP/IP model have different functionalities. Each layer of this model has different protocols to support. (Chauhan and Jain, 2020)
OSI Model
OSI model is the most widely used model in the world of networking. It is responsible to establish connections between devices. It is one of the general purpose networking model among computer network models, which is responsible to establish connection between all the devices present across the globe. (Shaw, 2020)
There are seven layers of OSI Model. These are
- Application layer
- Presentation layer
- Session layer
- Transport Layer
- Network Layer
- Data link layer
- Physical layer
Comparison of both models
OSI Model |
TCP/IP Model |
It is developed by ISO (International Standard Organization) |
It is developed by ARPANET (Advanced Research Project Agency Network). |
OSI model provides a clear contrast amongprotocols, services and interfaces. |
TCP/IP doesn't provide a clear contrast among services, interfaces, and protocols. |
OSI stand for Open Systems Interconnection. |
TCP stand for Transmission Control Protocol. |
Network layer of this model is responsible for routing standards and protocols. |
TCP/IP uses only the Internet layer. |
OSI follows a vertical approach. |
TCP/IP follows a horizontal approach. |
OSI model has seven layers. |
TCP/IP model has four layers. |
In this model, the transport layer is only connection oriented layer. |
All layers of the TCP/IP model are both connectionless and connection oriented. |
Data link layer and physical layers are separate layers in OSI model. |
In TCP model, physical layer and data link layer are combined as a single host-to-network layer. |
Session layer and presentation layer are a part of the OSI model. |
There is no session and presentation layer in the TCP model. |
It is defined after the advent of the Internet. |
It is defined before the advent of the internet. |
The minimum size of the OSI model header is 5 bytes. |
The minimum size of TCP model header is 20 bytes. |
Technologies used in Network Design
- DHCP
DHCP refers to Dynamic Host Configuration Protocol. It is one of the most widely used protocols now a day. It is use to dynamically configure the end devices by providing the IP address, DNS, subnet mask, default gateway and other parameters. (Kerravala, 2020) The main advantage of DHCP is time saving and thousands of devices can be configured in very little time. There is a very less chances of errors rather than manual configuration. Also we can set the lease time for the end device to hold any configuration which is a great feature. It is useful specially when an end user is a guest and we want to provide access for a limited period of time.
In this network design, I have configured DHCP in core switch. I have configured total 5 pools and these pools are associated with the VLAN and departments. - Domain Name System
DNS refers to Domain Name System, used to translate websites names to IP addresses. This can be done by DNS server only when DNS server has mappings of websites to IP addresses. It is one of the most important technology used in the internet world.(Rouse, 2020)
In this project, I have configured DNS server and added some mapping in the server. The DNS server is connected to the core switch. This server is accessible by every user of the department. - VLAN Trunking
VLAN trunking is basically a method of aggregating the physical network links into single logical link. Trunking provides a way of overcoming the bandwidth limitations of a single physical link and is used in both switch-to-switch and switch-to-server connections to relieve traffic congestion. (McQuerry, 2020)
Network Design
Figure-2
Description of Network Design
The above design is 2 tier model which consists of access layer and the core layer. Total four servers Web, DNS, Email and common files are connected to the core switch. There is 1 access point for wireless users are connected to the core switch. Then we have three departments and each department has different number of access switches depending upon the requirement of end user devices. Finance department has only one 24-port access switch because there are only 6 computers and 1 printer. Sales department has 3 access switches because of 52 computers and 1 printer. Admin department has 2 access switches because of 30 end computers and 1 printer. All the access switches are connected to the core switch. I have converted the end devices of all departments in to cluster for better visibility and understanding. The core switch is connected to the layer 3 switch. Layer 3 switch is used for inter VLAN routing as per requirement. All the departments have different VLANs and subnets
Department VLANs Details
Department |
VLAN |
Network |
Finance Department |
VLAN 2 |
71.81.91.0/26 |
Sales Department |
VLAN 3 |
71.81.91.64/26 |
Admin Department |
VLAN 4 |
71.81.91.128/26 |
Servers |
VLAN 5 |
71.81.91.192/26 |
Wireless |
VLAN 6 |
10.11.0.0/16 |
Table-3
Configuration of Core Switch
ipdhcp pool HR
network 71.81.91.0 255.255.255.192
default-router 71.81.91.1
ipdhcp pool Sales
network 71.81.91.64 255.255.255.192
default-router 71.81.91.65
ipdhcp pool Admin
network 71.81.91.128 255.255.255.192
default-router 71.81.91.129
ipdhcp pool servers
network 71.81.91.192 255.255.255.192
default-router 71.81.91.193
ipdhcp pool wireless
network 10.11.0.0 255.255.0.0
default-router 10.11.0.1
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 5
switchport mode access
interface FastEthernet0/1
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 4
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 5
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 5
switchport mode access
interface Vlan2
mac-address 0005.5e9e.2c01
ip address 71.81.91.1 255.255.255.192
!
interface Vlan3
mac-address 0005.5e9e.2c02
ip address 71.81.91.65 255.255.255.192
!
interface Vlan4
mac-address 0005.5e9e.2c03
ip address 71.81.91.129 255.255.255.192
!
interface Vlan5
mac-address 0005.5e9e.2c04
ip address 71.81.91.193 255.255.255.192
!
interface Vlan6
mac-address 0005.5e9e.2c05
ip address 10.11.0.1 255.255.0.0
!
Testing
References
Chauhan, A. and Jain, P., 2020. TCP/IP Model - Geeksforgeeks. [online] GeeksforGeeks. Available at:
Shaw, K., 2020. The OSI Model Explained And How To Easily Remember Its 7 Layers. [online] Network World. Available at:
Ram, V., 2020. OSI Vs. TCP/IP Reference Model. [online] Tutorialspoint.com. Available at:
Kerravala, Z., 2020. DHCP Defined And How It Works. [online] Network World. Available at:
Rouse, M., 2020. What Is The Domain Name System? - Definition From Whatis.Com. [online] SearchNetworking. Computer network assignment Available at:
McQuerry, S., 2020. Trunk Links > CCNA Self-Study (ICND Exam): Extending Switched Networks With Virtual Lans | Cisco Press. [online] Ciscopress.com. Available at: